summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a2bc133edc9..6aed1731c671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=glib2-patched-thumbnailer
pkgname=glib2-patched-thumbnailer
-pkgver=2.46.1
+pkgver=2.46.2
_patchver=d0edf118e1c27700300038c1d82b3ff775c0216b
pkgrel=1
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
@@ -19,25 +19,22 @@ options=('!docs' '!emptydirs')
license=('LGPL')
source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
revert-warn-glib-compile-schemas.patch
- https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch)
-sha256sums=('5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb'
+ https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch
+ memleak.patch)
+sha256sums=('5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
- '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d')
+ '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d'
+ '8337eeba4a32133d41575c8338fca32ac6a867e6e4a4e021355fcdeb606420a6')
prepare() {
cd glib-$pkgver
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+ patch -Np1 -i ../memleak.patch
patch -Np1 -i ${srcdir}/glib-thumbnailer.patch
}
-
+
build() {
cd glib-$pkgver
-
- ## Prevent runtime unloading of glib
- # https://bugs.archlinux.org/task/46619
- # https://bugzilla.gnome.org/show_bug.cgi?id=755609
- LDFLAGS+=" -Wl,-z,nodelete"
-
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --libdir=/usr/lib \
--sysconfdir=/etc \
--with-pcre=system \