summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 35 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4920ea7d57f..bce8504563da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,52 @@
pkgname=glib2-static
-pkgver=2.50.2
+pkgver=2.58.2
pkgrel=1
pkgdesc="Low level core library. Static library."
-url="http://www.gtk.org/"
-arch=(i686 x86_64)
-makedepends=(libffi pcre zlib shared-mime-info python libelf)
-checkdepends=(desktop-file-utils dbus)
-optdepends=('python2: for gdbus-codegen and gtester-report'
- 'elfutils: gresource inspection tool')
-options=('!docs' '!libtool' '!emptydirs' 'staticlibs')
+url="https://wiki.gnome.org/Projects/GLib"
+license=(LGPL2.1)
+arch=(x86_64)
depends=(pcre libffi)
-license=(LGPL)
-source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz
- revert-warn-glib-compile-schemas.patch)
-sha256sums=('be68737c1f268c05493e503b3b654d2b7f43d7d0b8c5556f7e4651b870acfbf5'
- '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
+makedepends=(libffi zlib shared-mime-info python libelf git util-linux meson dbus)
+checkdepends=(desktop-file-utils dbus)
+optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
+ 'libelf: gresource inspection tool')
+options=('!docs' '!libtool' '!emptydirs' '!strip' 'staticlibs')
+_commit=97bcbcb8c2aa0aeee5afd9939efbadbae0c8a8fa # tags/2.58.2^0
+source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
+ noisy-glib-compile-schemas.diff)
+sha256sums=('SKIP'
+ '81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531')
+
+pkgver() {
+ cd glib
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd glib-$pkgver
- patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
- NOCONFIGURE=1 ./autogen.sh
+ cd glib
+
+ # Suppress noise from glib-compile-schemas.hook
+ patch -Np1 -i ../noisy-glib-compile-schemas.diff
}
build() {
- cd glib-$pkgver
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --libdir=/usr/lib \
- --sysconfdir=/etc \
- --with-pcre=system \
- --disable-fam --enable-static
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson glib build \
+ --default-library static \
+ -D selinux=false \
+ -D man=true \
+ -D gtk_doc=false \
+ -Dinternal_pcre=false \
+ -Dfam=false
+ ninja -C build
}
check() {
- cd glib-$pkgver
- if ! make check; then
- # Rounding error in timer tests?
- # GLib:ERROR:timer.c:38:test_timer_basic: assertion failed (micros == ((guint64)(elapsed * 1e6)) % 1000000): (1 == 0)
- make check
- fi
+ meson test -C build
}
-
package() {
- cd glib-$pkgver
- make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
- for _i in "$pkgdir/usr/share/bash-completion/completions/"*; do
- chmod -x "$_i"
- done
- # Our gdb does not ship the required python modules, so remove it
+ DESTDIR="$pkgdir" meson install -C build
+
+ # Only install static library
rm -rf "$pkgdir/usr/"{bin,include,share,lib/glib-2.0,lib/pkgconfig} $pkgdir/usr/lib/*.so*
}