summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74e0d2717a1b..a6809018cb5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=glibc-dso
pkgname=(glibc-dso lib32-glibc-dso)
pkgver=2.33
-pkgrel=5
+pkgrel=6
arch=(x86_64)
provides=("glibc=${pkgver%%.r*}")
url='https://www.gnu.org/software/libc'
@@ -93,6 +93,7 @@ build() {
# remove fortify for building libraries
CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
+ CFLAGS=${CFLAGS/-Wp,-D_FORTIFY_SOURCE=2/}
#
CFLAGS=${CFLAGS/-fno-plt/}
@@ -129,6 +130,7 @@ build() {
# remove fortify for building libraries
CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
+ CFLAGS=${CFLAGS/-Wp,-D_FORTIFY_SOURCE=2/}
CFLAGS=${CFLAGS/-fno-plt/}
CXXFLAGS=${CXXFLAGS/-fno-plt/}