summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 18 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4616091c448..ff23b3496e3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
-# Maintainer: farseerfc <farseerfc@gmail.com>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: farseerfc <farseerfc@gmail.com>
pkgname=glmark2
-pkgver=2020.04
+pkgver=2021.02
pkgrel=1
-pkgdesc="OpenGL (ES) 2.0 benchmark"
-arch=('i686' 'x86_64')
-url="https://launchpad.net/glmark2"
-license=('GPL' 'zlib' 'custom')
-groups=()
-depends=('libjpeg-turbo' 'libpng' 'libx11' 'libxcb' 'libgl' 'python2')
-makedepends=()
-optdepends=()
-source=("https://github.com/glmark2/glmark2/archive/$pkgver.tar.gz")
-md5sums=('a90713700a740180fef3576f7ee3c9db')
-
-prepare(){
- cd "$srcdir/$pkgname-$pkgver"
- sed -i "s|-Werror ||g" wscript
-}
+pkgdesc="An OpenGL 2.0 and ES 2.0 benchmark"
+arch=('x86_64')
+url="https://github.com/glmark2/glmark2"
+license=('GPL' 'custom')
+depends=('egl-wayland' 'libjpeg-turbo' 'libpng' 'libx11' 'mesa' 'systemd-libs')
+makedepends=('meson' 'systemd' 'wayland-protocols')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('bebadb78c13aea5e88ed892e5563101ccb745b75f1dc86a8fc7229f00d78cbf1')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 ./waf configure --prefix=/usr --with-flavors x11-gl,x11-glesv2
- python2 ./waf
+ arch-meson "$pkgname-$pkgver" build \
+ -Dflavors=drm-gl,drm-glesv2,wayland-gl,wayland-glesv2,x11-gl,x11-glesv2
+ meson compile -C build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 ./waf install --destdir="$pkgdir/"
+ DESTDIR="$pkgdir" meson install -C build
+
+ cd "$pkgname-$pkgver"
+ install -Dm644 COPYING.SGI -t "$pkgdir/usr/share/licenses/$pkgname"
}