summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7637a3a55bf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Forest Crossman <cyrozap at gmail dot com>
+
+pkgname=globalplatformpro-git
+pkgver=0.3.6.r8.g3f2f96f
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://javacard.pro/globalplatform/"
+license=('LGPL3')
+depends=('java-environment')
+makedepends=('git' 'apache-ant')
+source=(
+ "$pkgname::git+https://github.com/martinpaljak/GlobalPlatformPro.git"
+ 'gp-pro'
+)
+sha256sums=(
+ 'SKIP'
+ 'a8769c37ac54b3e98645f509b011a290d7e914937de0158cc8f2a8fcef0e255e'
+)
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+ git submodule update --init --recursive
+}
+
+build() {
+ cd $pkgname
+ ant
+}
+
+package() {
+ # Install the executables
+ install -d "$pkgdir"/usr/bin/
+ install -m 755 gp-pro "$pkgdir"/usr/bin/
+ cd $pkgname
+ install -d "$pkgdir"/usr/share/java/globalplatformpro/
+ install -m 644 gp.jar "$pkgdir"/usr/share/java/globalplatformpro/
+}