summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f54e967302f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=glog-git
+pkgver=0.3.4.r88.gda816ea
+pkgrel=1
+pkgdesc="C++ implementation of the Google logging module"
+arch=('i686' 'x86_64')
+url="https://github.com/google/glog"
+license=('BSD')
+makedepends=('git')
+provides=('glog')
+conflicts=('glog')
+source=('git+https://github.com/google/glog.git')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "glog"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "glog"
+
+ aclocal
+ autoconf
+ automake -a
+
+ ./configure
+ make
+}
+
+check() {
+ cd "glog"
+
+ #make check
+}
+
+package() {
+ cd "glog"
+
+ make prefix="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/glog/LICENSE"
+}
+