summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 26 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83af8d828f48..21af84a12c79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,48 @@
-# Maintainer: Agorgianitis Loukas <agorglouk@gmail.com>
+# Maintainer: Joonas Henriksson <joonas.henriksson at gmail com>
+# Contributor: Agorgianitis Loukas <agorglouk@gmail.com>
+
pkgname=glslviewer-git
-pkgver=r753.8a4f4d7
+pkgver=r1470.99a990a
pkgrel=1
pkgdesc="Live GLSL coding render for MacOS and Linux"
arch=('i686' 'x86_64')
url="https://github.com/patriciogonzalezvivo/glslViewer"
license=('BSD-3-Clause')
-depends=('glfw')
-makedepends=('git')
-provides=("${pkgname%-VCS}")
-conflicts=("${pkgname%-VCS}")
-source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer"
- 'floating_wm_workaround.patch')
+depends=('glu' 'glfw-x11' 'ncurses' 'ffmpeg')
+makedepends=('cmake' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/patriciogonzalezvivo/glslViewer"
+ "git+https://github.com/patriciogonzalezvivo/ada")
md5sums=('SKIP'
- '20c838d28b2390c9dd6fa3491c920edc')
+ 'SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-VCS}"
+ cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/${pkgname%-VCS}"
- patch -p1 -i "$srcdir/floating_wm_workaround.patch"
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.deps/ada.url "$srcdir/ada"
+ git submodule update
}
build() {
- cd "$srcdir/${pkgname%-VCS}"
- make
+ cmake \
+ -S "${pkgname%-git}" \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ make -C build
}
package() {
- cd "$srcdir/${pkgname%-VCS}"
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m755 bin/glslViewer "$pkgdir/usr/bin/glslviewer"
- install -D -m755 bin/glslLoader "$pkgdir/usr/bin/glslloader"
+ make install -C build DESTDIR="$pkgdir"
+
+ install -D -m644 "${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
mkdir -p "$pkgdir/usr/share/$pkgname/examples/"
- cp -R examples/* "$pkgdir/usr/share/$pkgname/examples/"
+ cp -R "${pkgname%-git}"/examples/* "$pkgdir/usr/share/$pkgname/examples/"
chmod -R 755 "$pkgdir/usr/share/$pkgname/examples/"
}