summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50c24cd7c3d3..c21dd5a8661b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,21 @@ depends=('glfw')
makedepends=('git')
provides=("${pkgname%-VCS}")
conflicts=("${pkgname%-VCS}")
-source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer"
+ 'floating_wm_workaround.patch')
+md5sums=('SKIP'
+ '0d5e68722253fd33a25e57d7e2405a5c')
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-VCS}"
+ patch -p1 -i "$srcdir/floating_wm_workaround.patch"
+}
+
build() {
cd "$srcdir/${pkgname%-VCS}"
make