summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0933daf560ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+_pkgname=glualint
+pkgname=${_pkgname}-bin
+pkgver=1.11.1
+pkgrel=1
+pkgdesc="Linter for Garry's mod Lua."
+arch=('x86_64')
+_githubrepo="https://github.com/FPtje/GLuaFixer"
+url=${_githubrepo}
+license=('LGPL2.1')
+source=("${_githubrepo}/releases/download/${pkgver}/${_pkgname}-${pkgver}-linux.zip")
+sha256sums=('ea05a68e8f7d414e46b3388036c7c515bef793eee95aef922ae6908fc9a94972')
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}