summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 13 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e81171a8e4f..b2319032c1cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,27 @@
-# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
-# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
pkgname=gmines.app
_pkgname=GMines
-pkgrel=3
+pkgrel=1
pkgver=0.2
pkgdesc="A clone of the well-known minesweeper game."
arch=('i686' 'x86_64')
url="http://www.nongnu.org/gap/gmines/index.html"
license=('GPL')
-groups=('gnustep')
-depends=('gnustep-base'
- 'gnustep-gui')
-makedepends=('gcc-objc'
- 'gnustep-make')
-source=("http://savannah.nongnu.org/download/gap/$_pkgname-$pkgver.tar.gz")
+groups=('gnustep-games')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://savannah.nongnu.org/download/gap/GMines-0.2.tar.gz")
sha256sums=('a7100c9846b548ef2d27c35b80370b30769dca3ac8eeff5f15a227474843c067')
build() {
- cd "$_pkgname-$pkgver"
+ cd $_pkgname-$pkgver
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
package() {
- cd "$_pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
-}
-
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file