summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f71724a68f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Doug Elkin <aur@dougelkin.com>
+
+pkgname=gmocli
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="command-line interface for searching emoji characters with associated gitmoji descriptions"
+url='https://github.com/duhdugg/gmocli'
+license=('MIT')
+arch=(x86_64)
+depends=()
+optdepends=()
+makedepends=(cargo)
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+sha256sums=('6c8033e90dc3d0b7a5d725da7c9d1ac9c3a397e744eb050398450af063d54409')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm0755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm0644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm0644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 "data/emoji/unicode-license.txt" "$pkgdir/usr/share/licenses/$pkgname/thirdparty/unicode-license.txt"
+ install -Dm0644 "data/gitmoji/gitmoji-license.txt" "$pkgdir/usr/share/licenses/$pkgname/thirdparty/gitmoji-license.txt"
+}