summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a209ddd17fe0..0f02cacc9605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@
pkgname=gnatcoll-gmp
pkgver=2018
-pkgrel=1
+pkgrel=2
pkgdesc='GNAT Components Collection - Bindings to GMP'
url='https://github.com/AdaCore/gnatcoll-bindings/'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('gcc-ada' 'gmp' 'gnatcoll-core')
-makedepends=('gprbuild')
+depends=('gmp' 'gnatcoll-core>=2018')
+makedepends=('gprbuild>=2018')
-provides=('gnatcoll-gmp')
-conflicts=('gnatcoll-gmp')
+conflicts=('gnatcoll-gmp-git')
source=('http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5')
sha1sums=('42682c885e4a02bb03786aa9ece3a4214ca419f8')
@@ -22,7 +21,7 @@ sha1sums=('42682c885e4a02bb03786aa9ece3a4214ca419f8')
build()
{
cd "$srcdir/gnatcoll-bindings-gpl-2018-src/gmp"
- python2 setup.py build -j$(nproc) --prefix=/usr -R
+ python2 setup.py build -j1 --prefix=/usr -R
}
package()