summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87b06aa9bcff..1e644b403532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,15 @@ url="http://gnaural.sourceforge.net/"
license=('GPL')
depends=('libglade' 'portaudio')
install="$pkgname.install"
-source=("http://downloads.sourceforge.net/project/$pkgname/Gnaural/${pkgname}_${pkgver}.tar.xz")
-md5sums=('a3f909ca56466393c9eef42f25fc028b')
+source=("http://downloads.sourceforge.net/project/$pkgname/Gnaural/${pkgname}_${pkgver}.tar.xz"
+ "gnaural.patch")
+md5sums=('a3f909ca56466393c9eef42f25fc028b'
+ '7b8a6f84ca8aeb01cf5b46e76027c1b5')
build() {
cd "$srcdir/${pkgname}_${pkgver}"
- # Fix a bug where an inlined function isn't marked as extern. GCC seems to have tolerated rather long, but eventually broke.
- sed -i 's/#endif/extern inline void BB_ResetAllVoices ();\n#endif/g' src/main.h src/gnauralXML.h
- sed -i 's/^inline void BB_ResetAllVoices/void BB_ResetAllVoices/g' src/BinauralBeat.c
-
- # desktop file path fix
- sed -i "s|gnome/apps/Multimedia|applications|g" Makefile.*
+ patch --strip=1 < "$srcdir/gnaural.patch"
./configure --prefix=/usr
make