summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8d226483b10..92b815400dcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: gbr <gbr@protonmail.com>
pkgname=gnethogs
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc='GTK front-end for nethogs'
arch=('x86_64')
url='https://github.com/mbfoss/gnethogs'
@@ -14,10 +14,19 @@ makedepends=(
'intltool'
'libxml2'
)
-source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/mbfoss/gnethogs/archive/v${pkgver}.tar.gz")
-sha1sums=('1a9f2eace9536745191836ad063cbd4bce12d117')
+source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/mbfoss/gnethogs/archive/v${pkgver}.tar.gz"
+ "nethogsmonitor_init.patch"
+)
+sha1sums=('1a9f2eace9536745191836ad063cbd4bce12d117'
+ 'SKIP'
+)
install=gnethogs.install
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/nethogsmonitor_init.patch"
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./autogen.sh