summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8762f22ace2b..515d8c913fca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,29 @@
_name=gnome-2048
pkgname=$_name-git
-pkgver=3.26.1.r220.27eac00
+pkgver=3.31.4+30+g9179407
pkgrel=1
pkgdesc="Obtain the 2048 tile"
-arch=('x86_64')
+arch=(x86_64)
url="https://wiki.gnome.org/Apps/2048"
-license=('GPL')
-depends=('clutter-gtk' 'libgnome-games-support')
-makedepends=('git' 'intltool' 'appstream-glib' 'yelp-tools' 'vala')
-options=(!libtool)
+license=(GPL)
+depends=(clutter-gtk libgnome-games-support)
+makedepends=(git meson appstream-glib yelp-tools vala)
provides=($_name)
conflicts=($_name)
-source=("git+https://git.gnome.org/browse/$_name")
+source=("git+https://gitlab.gnome.org/GNOME/$_name.git")
md5sums=('SKIP')
pkgver() {
cd $_name
- v=$(grep AC_INIT configure.ac | cut -d[ -f3 | cut -d] -f1)
- printf "%s.r%s.%s" $v $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
-}
-
-prepare() {
- cd $_name
- ./autogen.sh NOCONFIGURE=1
+ git describe --tags | sed 's/-/+/g'
}
build() {
- cd $_name
- ./configure --prefix=/usr --disable-schemas-compile
- make
+ arch-meson $_name build -D b_pie='false'
+ ninja -C build
}
package() {
- cd $_name
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
}