summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62d44d73a091..639e4c6349a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,46 @@
-# Maintainer: lectrode <electrodexsnet@gmail.com>
-# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Maintainer: lectrode (electrodexsnet@gmail.com)
# Contributor: Edgar Vincent <e-v@posteo.net>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
_pkgname=gnome-clocks
pkgname=${_pkgname}-waked
-pkgver=43.0
-pkgrel=1.1
+pkgver=44.0
+pkgrel=1
pkgdesc="Clocks applications for GNOME (version with waked support)"
url="https://wiki.gnome.org/Apps/Clocks"
arch=(x86_64 aarch64)
license=(GPL)
provides=($_pkgname)
conflicts=($_pkgname)
-depends=(gtk4 libgweather-4 gnome-desktop-4 geoclue geocode-glib-2 gsound
- libadwaita waked)
-makedepends=(vala gobject-introspection yelp-tools git meson)
+depends=(
+ geoclue
+ geocode-glib-2
+ gnome-desktop-4
+ gsound
+ gtk4
+ libadwaita
+ libgweather-4
+ waked
+)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+ yelp-tools
+)
groups=(gnome)
-options=(!debug)
-_commit=9877dfa0ca9fcc2fcf73fd6d96b57226380baf4a # tags/43.0^0
+_commit=220460fde76ef779436dacb07bc3b0589995e608 # tags/44.0^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-clocks.git#commit=$_commit"
'0001-invoke-waked-when-an-alarm-changes.patch'
'0002-Add-argument-to-start-initial-instance-in-the-backgr.patch'
'0003-add-lock-screen-actions.patch'
'gnome-clocks.desktop')
-sha256sums=('SKIP'
- '6203b5c43ac1f23ca5c622ab75d23891de24b17e716546c5230ec89928ccf0be'
- 'a728598594b1fc7b0c40ebfa4b44ddd770dc33cc6590ef8518b987ccc4b6d0ce'
- '82bcab0a26dcb8a73719a690fc65c4003a2530ec27b066ea0f9336525e0e8a49'
- '37368c4f902facb6ed735df1c4edbd55fc477198246096929689dd0092f16fe2')
+b2sums=('SKIP'
+ 'f63bd443f2a95b0acfc40989cdaf5b02a857fda14949731e5cdda341e8a26dcd2740bc885bf93087f25224820f1abfdc581919f16f4c47c5591e3348d6917a47'
+ '940e1bc2d1756bf8c9f7ad26c5b58a6aeb9eb2110f2ab483e6789c32336d54af2679271f5823b5ad8aabf4643cdbb97624440696606f606a64b69379eee31708'
+ 'fcb286f9e4ed9381aa0c6ae46c4f4b27126d1e1236e59dec4f8fd564a5fe9f9c7041764e2ce3dc38af7393a0235aa41753167ad99434ba2ddbaf4e47fe12f8d5'
+ '1c3891a84f28bf8e8cbf7d0ad8f5d17a6993f91c686986193d5cf71c46368d7d6645de718f09cd4c6b69e4ed118333d02e22b4fb507c21ca55a54135a5c594fc')
pkgver() {
cd $_pkgname