summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb05786c914b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: alucryd <alucryd at gmail dot com>
+# Contributor: L42y <423300 at gmail dot com>
+# Contributor: teddy_beer_maniac <teddy_beer_maniac at wp dot pl>
+
+pkgname=gnome-common-git
+pkgver=3.14.0.r12.4363223
+pkgrel=1
+pkgdesc="Common development macros for GNOME"
+arch=('any')
+url="http://www.gnome.org"
+license=('GPL')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("git://git.gnome.org/${pkgname%-*}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "%s" "$(git describe --tags | sed 's/-/.r/; s/-g/./')"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ ./autogen.sh --prefix='/usr'
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: