summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 732243fa2b5d..b716867e695d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,7 @@ url='https://wiki.gnome.org/Apps/Games'
license=('GPL3')
makedepends=('git')
optdepends=('libretro-blastem: Sega Mega Drive support'
- 'libretro-bsnes: Super Nintendo Entertainment System support'
- 'libretro-bsnes-mercury-git: Alternative Super Nintendo Entertainment System support'
+ 'libretro-bsnes-mercury-git: Super Nintendo Entertainment System support'
# TODO: see if renaming module to desmume works
#'libretro-desmume2015: Nintendo DS support'
'libretro-dosbox-git: MS-DOS support'
@@ -21,13 +20,13 @@ optdepends=('libretro-blastem: Sega Mega Drive support'
# TODO: see if renaming module to beetle works
#'libretro-mednafen-ngp: Neo Geo Pocket Color'
#'libretro-mednafen-pce-fast: TurboGrafx support'
- 'libretro-mednafen-saturn-git: Sega Saturn support'
+ #'libretro-mednafen-saturn-git: Sega Saturn support'
#'libretro-mednafen-vb: Nintendo Virtual Boy support'
#'libretro-mednafen-wswan: WonderSwan support'
'libretro-mgba: Nintendo Game Boy Advance support'
'libretro-nestopia: Nintendo Entertainment System support'
'libretro-pcsx-rearmed-git: Sony PlayStation support'
- 'libretro-picodrive-git: Sega Genesis/Master System/CD/32X/Pico support'
+ 'libretro-picodrive: Sega Genesis/Master System/CD/32X/Pico support'
# Missing package
#'libretro-prboom: Doom support'
'libretro-prosystem-git: Atari 7800 support'
@@ -40,11 +39,4 @@ package() {
cd "$_srcname"
install -d "$pkgdir"/usr/lib/libretro/
install -t "$pkgdir"/usr/lib/libretro/ flatpak/libretro-cores/*.libretro
-
- # bsnes-mercury is available on the AUR, but doesn't build at the moment.
- # In general it's nice to provide the standard package as an option.
- cp "$pkgdir"/usr/lib/libretro/bsnes_mercury_balanced.libretro \
- "$pkgdir"/usr/lib/libretro/bsnes_balanced.libretro
- sed -i 's/bsnes-mercury/bsnes/;s/bsnes_mercury/bsnes/' \
- "$pkgdir"/usr/lib/libretro/bsnes_balanced.libretro
}