summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1a5cf871927..073f62784e3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Sung Mingi <FiestaLake@protonmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gnome-icon-theme
pkgver=3.12.0
-pkgrel=6
+pkgrel=7
pkgdesc="GNOME icon theme"
arch=(any)
depends=('hicolor-icon-theme' 'gtk-update-icon-cache' 'gnome-icon-theme-symbolic')
@@ -10,11 +11,19 @@ makedepends=('intltool' 'icon-naming-utils')
url="http://www.gnome.org"
license=('GPL')
options=('!emptydirs')
-source=(https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
-sha256sums=('359e720b9202d3aba8d477752c4cd11eced368182281d51ffd64c8572b4e503a')
+source=("https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz"
+ "0001-configure.ac-Do-not-manually-set-localedir.patch")
+sha256sums=('359e720b9202d3aba8d477752c4cd11eced368182281d51ffd64c8572b4e503a'
+ '02e47f80f36904071d7377d7b06083e3ce5f70c9b1ce2d190ac4a1bb90efcac8')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "../0001-configure.ac-Do-not-manually-set-localedir.patch"
+}
build() {
cd "$pkgname-$pkgver"
+ autoupdate && autoreconf
./configure --prefix=/usr
make
}
@@ -22,5 +31,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
- rm -f "${pkgdir}/usr/share/icons/gnome/icon-theme.cache"
+ rm -f "${pkgdir}/usr/share/icons/gnome/icon-theme.cache"
}