summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 37 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c345288ee2e9..102c0826a4ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,54 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=gnome-network-displays-git
-pkgver=0.90.3.r4.gb59cd2f
+pkgver=0.92.1.r2.g3453460
pkgrel=1
pkgdesc="Miracast implementation for GNOME"
-arch=('any')
+arch=('x86_64')
url="https://gitlab.gnome.org/GNOME/gnome-network-displays"
-license=('GPL3')
-depends=('gtk3' 'faac' 'gst-plugins-ugly' 'gst-rtsp-server' 'libpulse' 'libnm'
- 'python-gobject' 'x264' 'xdg-desktop-portal')
-makedepends=('git' 'meson' 'appstream-glib')
+license=('GPL-3.0-or-later')
+depends=(
+ 'avahi'
+ 'gst-plugins-bad'
+ 'gst-plugins-good'
+ 'gst-plugins-ugly'
+ 'gst-rtsp-server'
+ 'libadwaita'
+ 'libportal-gtk4'
+ 'libpulse'
+ 'networkmanager'
+ 'protobuf-c'
+ 'python-gobject'
+ 'xdg-desktop-portal'
+)
+makedepends=('git' 'meson')
+optdepends=('dnsmasq' 'gst-plugin-pipewire' 'gstreamer-vaapi')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://gitlab.gnome.org/GNOME/gnome-network-displays.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+
+ # https://gitlab.gnome.org/GNOME/gnome-network-displays/-/issues/272
+ sed -i -e "s/args: \['validate'/args: \['--nonet', 'validate'/" \
+ data/meson.build
}
build() {
- arch-meson "${pkgname%-git}" build
- ninja -C build
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ meson install -C build --destdir "$pkgdir"
}