summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD55
1 files changed, 24 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4724532578c..a636044ede4d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,48 @@
-# Maintainer: Robin Visser <rxvisser@gmail.com>
+# Maintainer: Robin Visser <rxvisser@gmail.com>
# Contributor: Filip Hendrik <stoatally@gmail.com>
-# Contributor: Rowan Lewis <rl@nbsp.io>
+# Contributor: Rowan Lewis <rl@nbsp.io>
-rplname=gnome-settings-daemon
pkgname=gnome-settings-daemon-volume-step-patch
-pkgver=3.24.2
+pkgver=3.24.3
pkgrel=1
-pkgdesc="The GNOME Settings daemon with an additional patch to allow configuration of volume steps"
-arch=('i686' 'x86_64')
+pkgdesc="GNOME Settings daemon with an additional patch to allow configuration of volume steps"
+url="http://www.gnome.org"
+arch=(x86_64)
license=('GPL')
-depends=(
- 'dconf' 'gnome-desktop' 'gsettings-desktop-schemas' 'libcanberra-pulse'
- 'libgudev' 'libnotify' 'libsystemd' 'libwacom' 'pulseaudio' 'pulseaudio-alsa'
- 'upower' 'librsvg' 'libgweather' 'geocode-glib' 'geoclue2' 'nss'
-)
-makedepends=(
- 'intltool' 'xf86-input-wacom' 'libxslt' 'docbook-xsl' 'python2'
-)
+depends=(dconf gnome-desktop gsettings-desktop-schemas libcanberra-pulse libnotify libsystemd
+ libwacom pulseaudio pulseaudio-alsa upower librsvg libgweather geocode-glib geoclue2 nss
+ libgudev gtk3-print-backends libnm)
+makedepends=(intltool xf86-input-wacom libxslt docbook-xsl python git gnome-common)
provides=('gnome-settings-daemon')
conflicts=('gnome-settings-daemon')
options=('!emptydirs')
install=gnome-settings-daemon.install
-url="http://www.gnome.org"
groups=('gnome')
-source=(
- https://download.gnome.org/sources/$rplname/${pkgver:0:4}/$rplname-$pkgver.tar.xz
- volume-step.patch
-)
-sha256sums=('4aa9d72644e3ee8a30096a38986b0e9543fca92f586c561f6c8a11fb8148dcca'
+source=(https://download.gnome.org/sources/${pkgname:0:21}/${pkgver:0:4}/${pkgname:0:21}-$pkgver.tar.xz
+ volume-step.patch)
+sha256sums=('68c46038bc32b7cbe933cc24fa9f1eb96127d9900c07627767ab0a802f948593'
'754b89fbb2fd1da0f431e53b9aeaab511734234031c57c62d4747cfafeef2438')
prepare() {
- cd $rplname-$pkgver
+ cd ${pkgname:0:21}-$pkgver
- # https://bugzilla.gnome.org/show_bug.cgi?id=650371#c42
- patch -p1 -i ../volume-step.patch
+ # https://bugzilla.gnome.org/show_bug.cgi?id=650371
+ patch -p1 -i ../volume-step.patch
}
build() {
- cd $rplname-$pkgver
+ cd ${pkgname:0:21}-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/$rplname --disable-static
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/${pkgname:0:21} --disable-static
- # https://bugzilla.gnome.org/show_bug.cgi?id=656231
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ # https://bugzilla.gnome.org/show_bug.cgi?id=656231
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ make
}
package() {
- cd $rplname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd ${pkgname:0:21}-$pkgver
+ make DESTDIR="$pkgdir" install
}