summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05f0907b3cb2..f9d033287083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Que Quotion <quequotion@bugmenot.org>
-# Contributor: tobias <tobias@archlinux.org>
+# $Id$
+# Maintainer: tobias <tobias@archlinux.org>
pkgbase=gnome-sharp
-pkgname=('gnome-sharp' 'art-sharp' 'gconf-sharp-peditors' 'libgnome-sharp' 'gnome-vfs-sharp')
-pkgver=2.24.3
-pkgrel=1
+pkgname=('gnome-sharp' 'art-sharp' 'gconf-sharp' 'gconf-sharp-peditors' 'libgnome-sharp' 'gnome-vfs-sharp')
+pkgvermajor=2
+pkgverminor=24
+pkgverpatch=4
+pkgver=${pkgvermajor}.${pkgverminor}.${pkgverpatch}
+pkgrel=5
arch=(i686 x86_64)
license=(LGPL)
url="http://gtk-sharp.sourceforge.net"
makedepends=('gtk-sharp-2' 'libgnomeui' 'monodoc')
-source=("${pkgbase}-${pkgver}::git+https://github.com/mono/gnome-sharp"
- 02_fix_pkg-config_paths.patch
- 04_initialize_dbus_glib_threading.patch)
-md5sums=('SKIP'
- 'a8c1bf57a384f5fc20a5890f9f1cef5a'
- '90cd7ea88aaa3011522376153433d115')
+source=(https://github.com/mono/${pkgbase}/archive/${pkgver}.tar.gz
+ 06_fix_mono_path.patch)
+md5sums=('c3da83bfaa81eb8bac39d7b2232e2604'
+ '923434786ec049eed71a68a0825a3d60')
build() {
# get rid of that .wapi errors; thanks to brice
@@ -22,9 +23,8 @@ build() {
mkdir -p "${MONO_SHARED_DIR}"
cd "${srcdir}/${pkgbase}-${pkgver}"
- patch -Np1 -i ../04_initialize_dbus_glib_threading.patch
- patch -Np1 -i ../02_fix_pkg-config_paths.patch
- ./bootstrap-2.24 --prefix=/usr --sysconfdir=/etc
+ patch -Np1 -i ../06_fix_mono_path.patch
+ ./bootstrap-${pkgvermajor}.${pkgverminor} --prefix=/usr --sysconfdir=/etc
make
}
@@ -41,6 +41,14 @@ package_art-sharp() {
make -C art install DESTDIR="${pkgdir}"
}
+package_gconf-sharp() {
+ pkgdesc="Mono bindings for GConf"
+ depends=('gtk-sharp-2' 'gconf')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ make -C gconf/GConf install DESTDIR="${pkgdir}"
+ make -C gconf/tools install DESTDIR="${pkgdir}"
+}
package_gconf-sharp-peditors() {
pkgdesc="Mono bindings for GConf - Property Editing classes"
@@ -65,3 +73,4 @@ package_gnome-vfs-sharp() {
cd "${srcdir}/${pkgbase}-${pkgver}"
make -C gnomevfs install DESTDIR="${pkgdir}"
}
+