summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3f8c85a99ac..8641e91ca32e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
-pkgver=10
-pkgrel=1
+pkgver=v10.r2.g2e81270
+pkgrel=2
+_commit=2e81270c728f421f915900cab2725a8e20c87b0a
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
+install=${pkgname%-git}.install
license=('GPL')
depends=('gnome-shell>=3.38')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('d3b5646d679025f2e1f60ebf0413dbe0eb5d1f2cd437d45a86375c0002f52dc1')
+source=("${pkgname%-git}::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git#commit=$_commit")
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
package() {
- _reponame="applications-overview-tooltip"
_uuid="applications-overview-tooltip@RaphaelRochet"
-
- cd "${srcdir}/${_reponame}-${pkgver}"
- local dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- mkdir -p "${dir}"
- cp -R * "${dir}"
+ cd "${srcdir}"
+ chmod -R 644 ./*
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/"
+ mv ${pkgname%-git} ${_uuid}
+ cp -r "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ #rebuild compiled schemas if missimg
+ if [[ ! -f "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas/gschemas.compiled" ]]; then
+ glib-compile-schemas ${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas
+ fi
+ chmod -R 755 "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/"
}