summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8de36cc94914..d57423083493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
# Maintainer: Christian Schendel <doppelhelix@gmail.com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
pkgver=16.r0.gdac0b90
-pkgrel=2
+pkgrel=3
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
-install=${pkgname%-git}.install
license=('unknown')
depends=('gnome-shell>=1:40')
-makedepends=('git'
- 'glib2')
+makedepends=('git')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
-options=('!strip')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -26,13 +23,15 @@ package() {
local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
local schema=$(grep -Po '(?<="settings-schema": ")[^"]*' metadata.json).gschema.xml
local destdir="${pkgdir}/usr/share/gnome-shell/extensions/${uuid}"
- install -dm755 "${destdir}"
- find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|mo|compiled)$" -exec \
- install -Dm 644 {} ${destdir}/{} \;
+ install -d "${destdir}"
+ find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|md|png|compiled)$" -exec \
+ install -Dm644 {} ${destdir}/{} \;
install -Dm644 "${srcdir}/${pkgname%-git}/schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
-# rebuild compiled GSettings schemas if missing
- if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
- glib-compile-schemas "${destdir}/schemas"
- fi
+
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${uuid}/schemas/"
+
+ find . -regextype posix-egrep -regex ".*\.(mo)$" -exec \
+ install -Dm644 {} ${pkgdir}/usr/share/{} \;
+
}