summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa2587aeab57..bf55d4506779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
+# Maintainer: skrewball <aur at joickle dot com>
# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
# Contributor: Michael Wendland <dev at michiwend dot com>
+_pkgname=arch-update
pkgname=gnome-shell-extension-arch-update
-pkgver=47
+pkgver=48
pkgrel=1
pkgdesc="Convenient indicator for Arch Linux updates in GNOME Shell."
arch=('any')
@@ -11,22 +13,21 @@ license=('GPL3')
depends=('fakeroot' 'gnome-shell' 'pacman-contrib')
conflicts=('gnome-shell-extensions-git')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha512sums=('c9aed4da2d5c1a352228d1a8f17a73567e3d77267dd373240b297c66369c2780998b79f624156a71e37665f57f7644a1c3ce8a4e8dbb4d20e3169e3b9a41aa7a')
+sha256sums=('fbded2e97fa589e2206f725bdfdd7f6220930e60e63a39cfe2a723a95ee67c60')
package() {
- # Locate the extension.
- cd "$(dirname $(find -name 'metadata.json' -print -quit))"
- _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
- # Copy extension files into place.
- find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "${_destdir}" '{}' +
- find -maxdepth 2 \( -iname '*.svg*' \) -exec install -Dm644 -t "${_destdir}/icons" '{}' +
- install -Dm644 prefs.xml "${_destdir}"
- find -name '*.gschema.xml' -exec install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" '{}' +
+ cd "${_pkgname}-${pkgver}"
+ local _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ local _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+
+ install -Dm644 -t "${_destdir}" metadata.json *.js *.xml *.css
+ cp -r --no-preserve=ownership,mode icons "${_destdir}"
+ install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" schemas/*.xml
+
cd locale
for locale in */
do
- install -Dm644 -t "${_destdir}/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
+ install -Dm644 -t "${pkgdir}/usr/share/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
done
}