summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fb55f85f438..58ebab7e9599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
pkgname=gnome-shell-extension-background-logo-git
_name=background-logo-extension
-pkgver=3.24.0.r0.g16d6fe2
+pkgver=3.32.0.r0.g26fce06
pkgrel=1
pkgdesc="GNOME Shell extension to overlay a logo over the default background"
arch=(any)
url="https://pagure.io/background-logo-extension"
+depends=('gnome-shell' 'gnome-backgrounds')
source=(git+${url} 'archlinux-wm-gnome.svg')
sha256sums=('SKIP' 'ae3223dab86d51ed54ac22c0518102bcd965fe0576839a038e559301cf94cc2c')
license=(GPL3)
@@ -17,15 +18,14 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_name}"
- ./autogen.sh --prefix=/usr
- make
+ arch-meson background-logo-extension build
+ ninja -C build
}
package() {
- depends=('gnome-shell' 'gnome-backgrounds')
cd "${srcdir}/${_name}"
sed -i "s@/usr/share/fedora-logos/fedora_lightbackground.svg@/usr/share/archlinux-logos/archlinux_lightbackground.svg@g" schemas/org.fedorahosted.background-logo-extension.gschema.xml
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}"
+ DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${srcdir}"/archlinux-wm-gnome.svg $pkgdir/usr/share/archlinux-logos/archlinux_lightbackground.svg
}