summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc97233fde5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nattgew <nattarchy at gmail dot com>
+
+pkgname=gnome-shell-extension-bitcoin-markets-git
+pkgdesc="Displays Bitcoin and Altcoin market information in the Gnome Shell."
+pkgver=176.6a12763
+pkgrel=1
+arch=(any)
+url='https://github.com/OttoAllmendinger/gnome-shell-bitcoin-markets/'
+license=(MIT)
+depends=('gnome-shell')
+makedepends=('git zip unzip gjs')
+source=("$pkgname::git://github.com/OttoAllmendinger/gnome-shell-bitcoin-markets.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/"$pkgname"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir"/"$pkgname"
+ make
+ mkdir -p $pkgdir/usr/share/gnome-shell/extensions/bitcoin-markets@ottoallmendinger.github.com
+ unzip -q gnome-shell-bitcoin-markets.zip -d $pkgdir/usr/share/gnome-shell/extensions/bitcoin-markets@ottoallmendinger.github.com
+ #rm gnome-shell-bitcoin-markets.zip
+ chmod -R 644 $pkgdir/usr/share/gnome-shell/extensions/*
+}