summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eca1c10ab139..1d7231091916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,34 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=gnome-shell-extension-bumblebee-status-git
-_gitname=gnome-shell-extension-bumblebee-status
pkgver=r14.17cd4c1
pkgrel=1
pkgdesc="GNOME Shell extension that shows the status of the NVIDIA GPU"
arch=('any')
-url="https://github.com/dsboger/gnome-shell-extension-bumblebee-status"
+url="https://github.com/heatray/gnome-shell-extension-bumblebee-status"
license=('GPL3')
depends=('gnome-shell' 'unzip')
makedepends=('git')
-source=('git+https://github.com/dsboger/gnome-shell-extension-bumblebee-status.git')
+source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
./autogen.sh
./configure --prefix=/usr
- make ${MAKEFLAGS} zip-file
+ make
}
package() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
- _extid="gnome-shell-extension-bumblebee-status.dsboger@gmail.com"
- _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
-
- install -dm755 "${_extpath}"
-
- unzip -q -d "${_extpath}" "${_gitname}.zip"
+ make DESTDIR="${pkgdir}" install
}