summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0c75196f4b1..46ab663923e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gnome-shell-extension-dash-to-dock
_pkgname=dash-to-dock
pkgver=72
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Move the dash out of the overview transforming it in a dock"
arch=('any')
@@ -15,14 +15,21 @@ url="https://micheleg.github.io/dash-to-dock/"
license=('GPL')
depends=('gnome-shell')
makedepends=('intltool' 'gettext' 'git' 'sassc')
-_commit=ce45bfe0666592038477235e6ac776385dfd884f
-source=("git+https://github.com/micheleg/dash-to-dock.git#commit=$_commit")
-sha256sums=('SKIP')
+_commit=fc795c52b7f973eee065547c4d3eb92a6cbada4a
+source=("git+https://github.com/micheleg/dash-to-dock.git#commit=$_commit"
+ "1720.patch")
+sha256sums=('SKIP'
+ 'f9f1c15e6e1cdfa027478f35ded42fdbb438b7f98650f9f54c9145a36cdd6fa3')
pkgver() {
cd "${srcdir}"/${_pkgname}
- #git describe --tags | sed 's/^extensions\.gnome\.org-v//g' | sed 's/-/+/g'
- git describe --tags | sed 's/^extensions\.gnome\.org-v//g' | sed 's/-/+/g' | sed 's/ubuntu+dock+//g' | sed 's/_ubuntu5//g'
+ git describe --tags | sed 's/^extensions\.gnome\.org-v//g' | sed 's/-/+/g'
+}
+
+prepare() {
+ cd "${srcdir}"/${_pkgname}
+ # https://github.com/micheleg/dash-to-dock/pull/1720
+ patch -Np1 -i ../1720.patch
}
build() {