summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44e57c010dee..d6764006fc46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gnome-shell-extension-dash-to-dock
pkgver=55
-pkgrel=1
+pkgrel=2
pkgdesc="move the dash out of the overview transforming it in a dock"
arch=('any')
url="https://micheleg.github.io/dash-to-dock/"
@@ -38,7 +38,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}