summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dc36dbd55bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Rafal Malachowicz <k5hv@linux.pl>
+# Based on gnome-shell-extension-gnomenu PKGBUILD maintained by: Scott Dickson <scottfoesho@gmail.com>
+
+_pkgname=gnome-shell-extension-gnomenu
+pkgname=$_pkgname-git
+pkgver=v25.g21c5623
+pkgrel=1
+pkgdesc="GnoMenu - is a traditional styled full featured Gnome-Shell apps-menu, that aims to offer all the essentials in a simple uncluttered intuitive interface."
+arch=('any')
+url="https://github.com/The-Panacea-Projects/Gnomenu"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+conflicts=($_pkgname)
+source=('git+https://github.com/The-Panacea-Projects/Gnomenu')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Gnomenu"
+ git describe --long --tags | cut -d '.' -f 2 | awk -F '-' '{print $1"."$3}'
+}
+
+package() {
+ _extname='gnomenu@panacier.gmail.com'
+
+ cd "$srcdir/Gnomenu"
+ rm README.md Screenshot.png
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_extname}"
+ cp -r . "$pkgdir/usr/share/gnome-shell/extensions/${_extname}/"
+}