summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc3812c0f037..b9569ebb3643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=gnome-shell-extension-ibus-tweaker-git
commit=ad2b8a4
pkgver=20230402+${commit}
-pkgrel=1
+pkgrel=2
pkgdesc="Tweaker of ibus in gnome-shell for orientation, theme, font and input mode auto-switch."
arch=('any')
url="https://github.com/tuberry/ibus-tweaker"
license=('GPL3')
-depends=('gnome-shell>=44.0')
+depends=('gnome-shell>=43.0')
makedepends=('git' 'gettext' 'glib2' 'meson' 'sassc')
conflicts=('gnome-shell-extension-ibus-tweaker')
provides=('gnome-shell-extension-ibus-tweaker')
@@ -19,10 +19,12 @@ sha256sums=('SKIP')
build() {
cd "ibus-tweaker"
git reset --hard ${commit}
+ git clean -fxd
git submodule init
git submodule update
meson setup build -Dtarget=system --prefix /usr
meson install -C build --destdir "${srcdir}"
+ sed -i -E 's|^(\s*)"44"\s*$|\1"43"|g' "${srcdir}/usr/share/gnome-shell/extensions/ibus-tweaker@tuberry.github.com/metadata.json"
}
package() {