summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 40 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd945f2cb891..a5e2bdf31387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,64 @@
-# Maintainer: Morris Jobke <hey at morrisjobke dot de>
+# Maintainer: XZS <d dot f dot fischer at web dot de>
+# Contributor: Morris Jobke <hey at morrisjobke dot de>
# Contributor: alucryd <alucryd at gmail dot com>
+# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
+# You may find it convenient to file issues and pull requests there.
pkgname=gnome-shell-extension-mediaplayer-git
-pkgver=3.10.r445.2b62dc0
+pkgver=r502.89216cd
pkgrel=1
pkgdesc='A mediaplayer indicator for the Gnome Shell'
arch=('any')
url='https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer'
license=('GPL2')
-depends=('gnome-shell')
-makedepends=('git' 'gnome-common' 'intltool')
+makedepends=('gnome-common' 'intltool')
optdepends=('mpdris2-git: MPD support')
-install=${pkgname%-*}.install
-source=("${pkgname%-*}::git+${url}.git")
-sha256sums=('SKIP')
+install=gschemas.install
+makedepends+=('git')
+source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
+md5sums+=('SKIP')
+provides+=($_gitname)
+conflicts+=($_gitname)
pkgver() {
- cd ${pkgname%-*}
-
- printf "3.10.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${_gitname:-$pkgname}
+ git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
+ [ ${PIPESTATUS[0]} -ne 0 ] && \
+printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd ${pkgname%-*}
-
+ cd "$_gitname"
./autogen.sh
./configure --prefix='/usr' --disable-schemas-compile
make
}
package() {
- cd ${pkgname%-*}
+ for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
+ do
+ $function
+ done
+}
+package_01_make_install() {
+ cd "$_gitname"
make DESTDIR="${pkgdir}" install
}
-# vim: ts=2 sw=2 et:
+depends[125]=gnome-shell
+
+package_20_version() {
+ local compatibles=($(\
+ find -path ./pkg -type d -prune -o \
+ -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \
+ tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
+ depends+=("gnome-shell>=3.${compatibles[0]}")
+ local max="${compatibles[-1]}"
+ if [ "3.$max" != $(
+ gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
+ ) ]; then
+ depends+=("gnome-shell<3.$((${max%%.*} + 1))")
+ fi
+ unset depends[125]
+}