summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abaa28c465b4..8adf5501a6ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=gnome-shell-extension-mullvad-indicator-git
-pkgver=44.r5.gd031864
-pkgrel=2
+_uuid=mullvadindicator@pobega.github.com
+pkgver=45.r1.g7727c09
+pkgrel=1
pkgdesc="GNOME extension to track Mullvad connectivity"
arch=('any')
url="https://github.com/Pobega/gnome-shell-extension-mullvad-indicator"
@@ -14,23 +15,21 @@ source=('git+https://github.com/Pobega/gnome-shell-extension-mullvad-indicator.g
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
make
}
package() {
- _uuid='mullvadindicator@pobega.github.com'
-
- cd "$srcdir/${pkgname%-git}"
- install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
- bsdtar -xvf $_uuid.zip -C "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/" --no-same-owner
+ cd "${pkgname%-git}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+ bsdtar -xvf ${_uuid}.zip -C "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/" --no-same-owner
install -Dm644 schemas/org.gnome.shell.extensions.MullvadIndicator.gschema.xml -t \
"$pkgdir/usr/share/glib-2.0/schemas/"
- rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas/"
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/schemas"
}