summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5902a41a71e5..1bd090ff57c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
-# $Id$
# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
pkgname=gnome-shell-extension-proxy-switcher-git
-pkgver=1.2.r6.g549d1aa
+pkgver=2.0.r0.gdec14a0
pkgrel=1
pkgdesc='Extension for GNOME shell to switch between the system proxy settings.'
arch=(any)
@@ -10,7 +9,7 @@ _githubname=proxy-switcher
_githubowner=tomflannaghan
url="https://github.com/${_githubowner}/${_githubname}"
license=(GPL2)
-depends=('gnome-shell>=3.18')
+depends=('gnome-shell>=43.0')
makedepends=('git' 'python')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -19,23 +18,24 @@ source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_githubname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_githubname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_githubname}"
- sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
- Makefile
+ cd "${srcdir}/${_githubname}"
+ sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
+ Makefile
}
+
build() {
- cd "${srcdir}/${_githubname}"
- make build
+ cd "${_githubname}"
+ make build
}
package() {
- cd "${srcdir}/${_githubname}"
- install -d "$pkgdir/usr/share/gnome-shell/extensions"
- make DESTDIR="$pkgdir" install
+ cd "${_githubname}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ make DESTDIR="${pkgdir}" install
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et: