summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36542e782af2..2f3a4054d464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=gnome-shell-extension-screenshot-git
-pkgver=137.9bec3b3
-pkgrel=1
+pkgver=r137.9bec3b3
+pkgrel=2
pkgdesc="Gnome Shell extension for making and uploading screenshots"
arch=('any')
url="https://github.com/OttoAllmendinger/gnome-shell-screenshot"
@@ -13,15 +13,16 @@ source=("${pkgname}::git+https://github.com/OttoAllmendinger/gnome-shell-screens
md5sums=('SKIP')
pkgver() {
- cd ${pkgname}
+ cd ${pkgname}
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${pkgname}
- _extid="gnome-shell-screenshot@ttll.de"
- _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+ cd ${pkgname}
- make EXTENSION_PATH=${_extpath} install
+ _extid="gnome-shell-screenshot@ttll.de"
+ _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+
+ make EXTENSION_PATH=${_extpath} install
}