summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e1ee6823d03..6644eb8db9ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,27 @@
pkgname=gnome-shell-extension-screenshot-git
pkgver=r150.6b67d49
-pkgrel=1
+pkgrel=2
pkgdesc="Gnome Shell extension for making and uploading screenshots"
arch=('any')
url="https://github.com/OttoAllmendinger/gnome-shell-screenshot"
license=('MIT')
depends=('gnome-shell')
-makedepends=('git' 'zip')
+makedepends=('git' 'zip' 'eslint')
source=("${pkgname}::git+https://github.com/OttoAllmendinger/gnome-shell-screenshot.git")
md5sums=('SKIP')
pkgver() {
- cd ${pkgname}
+ cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${pkgname}
+ cd "${srcdir}/${pkgname}"
_extid="gnome-shell-screenshot@ttll.de"
_extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
- make EXTENSION_PATH=${_extpath} install
+ make EXTENSION_PATH="${_extpath}" install
}