summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b4abf73acda..12416888ba37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,27 @@
pkgname=gnome-shell-extension-topicons-plus
pkgver=27
-pkgrel=4
+pkgrel=5
pkgdesc="Moves legacy tray icons to the top panel"
arch=('any')
url="https://github.com/phocean/TopIcons-plus"
license=('GPL2')
depends=('gnome-shell')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz"
- "0001-fix-compatibility-with-gnome40_41.diff")
+ "0001-fix-compatibility-with-gnome40.patch"
+ "0002-Declare-compatibility-with-GNOME-Shell-41.patch"
+ "0003-Declare-GNOME-Shell-42-compatibility.patch")
sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8'
- '0a1f5537c1fe985e666858d40edc1c8a9849bd74c0ea6b4a94ea21c838dad54c')
+ 'e3ed60fd7d9830ac53cf34adee24c26fab1092660705d079bbb15e15a82b6381'
+ 'e4106d408a90af0d7c633cce394c276d35e2a69111758ad3229b42f8e19e53b8'
+ '65b6970d4aadfcfce256e4830fde711a5aad3fd328ce9cb42e5b7457047c866f')
prepare() {
cd "${srcdir}/TopIcons-plus-${pkgver}"
- patch -p1 -i ${srcdir}/0001-fix-compatibility-with-gnome40_41.diff
+ patch -p1 -i ${srcdir}/0001-fix-compatibility-with-gnome40.patch
+ patch -p1 -i ${srcdir}/0002-Declare-compatibility-with-GNOME-Shell-41.patch
+ patch -p1 -i ${srcdir}/0003-Declare-GNOME-Shell-42-compatibility.patch
}
build(){