summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0014ed62b12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=gnome-shell-extension-transparent-top-bar-git
+pkgver=r10.31714cf
+pkgrel=1
+pkgdesc="Bring back the transparent top bar when free-floating in GNOME Shell 3.32"
+arch=(any)
+url="https://extensions.gnome.org/extension/1708/transparent-top-bar/"
+license=(GPL)
+depends=(gnome-shell)
+makedepends=(git)
+provides=(gnome-shell-extension-transparent-top-bar)
+conflicts=(gnome-shell-extension-transparent-top-bar)
+source=("git+https://github.com/zhanghai/gnome-shell-extension-transparent-top-bar.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd gnome-shell-extension-transparent-top-bar
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd gnome-shell-extension-transparent-top-bar
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/transparent-top-bar@zhanghai.me"
+ install -t "${pkgdir}/usr/share/gnome-shell/extensions/transparent-top-bar@zhanghai.me" src/*
+}