summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0b63a2d7551
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=gnome-shell-extension-workspaces-bar-git
+_pkgname=workspaces-bar
+pkgver=r9.47a4e9d
+pkgrel=1
+pkgdesc="GNOME Shell extension that shows workspaces buttons in top panel"
+arch=('any')
+url="https://github.com/fthx/workspaces-bar"
+license=('unknown')
+depends=('gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/fthx/workspaces-bar.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ _uuid='workspaces-bar@fthx'
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ cp -r $(ls -A | grep -vE '.git') \
+ "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+}