summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b764b578c700..606ae3ef94ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
### MERGE REQUESTS SELECTION
-# available MR: ('536' '786' '923')
-_merge_requests_to_use=('1205' '1126' '1192' '1164') # safe pick
+# available MR: ('536' '786' '923' '1126 '1164' '1192' '1205' )
+_merge_requests_to_use=() # safe pick
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -23,11 +23,12 @@ arch=(x86_64)
license=(GPL2)
depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libgdm libsecret
- mutter nm-connection-editor unzip gstreamer libibus gnome-autoar 'gjs-git')
+ mutter nm-connection-editor unzip gstreamer libibus gnome-autoar)
makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
sassc asciidoc bash-completion)
optdepends=('gnome-control-center: System settings'
- 'evolution-data-server: Evolution calendar integration')
+ 'evolution-data-server: Evolution calendar integration'
+ 'gjs-git: Needed if using MR !1164')
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
conflicts=(gnome-shell)
@@ -35,10 +36,12 @@ install=$pkgname.install
_commit=890f5b591fef3cc3af387675c53113a5226805d1 # tags/3.36.1^40
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- "1126.diff")
+ "1126.diff"
+ "1205.diff")
sha256sums=('SKIP'
'SKIP'
- '32661c22298d0c4af9b6b6bb718480ce192f528367f853d9709f74c146b2f8d4')
+ '32661c22298d0c4af9b6b6bb718480ce192f528367f853d9709f74c146b2f8d4'
+ 'f384ca71ce47052e244811cfdfced7fab7752600de6d5b96380e92cc5fd335e1')
pkgver() {
cd $_pkgname
@@ -134,7 +137,7 @@ prepare() {
# Status: 4
# Comment: Depends on 1126 that requires gjs>=1.65.1
pick_mr '1126' '1126.diff' 'patch'
- pick_mr '1205'
+ pick_mr '1205' '1205.diff' 'patch' #fixes some gjs warnings
pick_mr '1192'
pick_mr '1164'