summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 676a56568712..0bb426447b59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,17 @@
+# Patched package:
+# Maintainer: Saren Arterius <saren@wtako.net>
+# Co-maintainer: Térence Clastres <t.clastres@gmail.com>
+# Co-maintainer: Sung Mingi <FiestaLake@protonmail.com>
+
+# Official package:
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
-# Patched package maintainer: Saren Arterius <saren@wtako.net>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Flamelab <panosfilip@gmail.com
### MERGE REQUESTS SELECTION
-# available MR: ('536' '786' '923' '1440')
+# available MR: ('536' '786' '923')
_merge_requests_to_use=()
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -14,7 +19,7 @@ _merge_requests_to_use=()
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=40.5
+pkgver=41.1
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
@@ -24,7 +29,8 @@ license=(GPL)
depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gtk4
gnome-settings-daemon gnome-themes-extra gsettings-desktop-schemas
libcanberra-pulse libgdm libsecret mutter nm-connection-editor unzip
- gstreamer libibus gnome-autoar gnome-disk-utility gst-plugin-pipewire)
+ gstreamer libibus gnome-autoar gnome-disk-utility gst-plugin-pipewire
+ libsoup3)
makedepends=(gtk-doc gnome-control-center evolution-data-server
gobject-introspection git meson sassc asciidoc bash-completion)
checkdepends=(xorg-server-xvfb)
@@ -33,7 +39,7 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver gnome-shell=$epoch:$pkgver)
conflicts=(gnome-shell)
-_commit=ad6f45f403fce7922392c43f30059c4af2aac561 # tags/40.5^0
+_commit=a1b537eebf1b7cfb7249fa33c7fbb9ee6ac55b69 # tags/41.1^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
@@ -133,13 +139,6 @@ prepare() {
# Comment: Unlock freezes, it hits me too.
pick_mr '923'
- # Avoid missing/broken app launch animations
- # URL: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/1440
- # Type: 3
- # Status: 2
- # Comment:
- pick_mr '1440'
-
git submodule init
git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
git submodule update
@@ -154,12 +153,11 @@ check() (
mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
export XDG_RUNTIME_DIR
- dbus-run-session xvfb-run \
- -s '-screen 0 1920x1080x24 -nolisten local +iglx -noreset' \
- meson test -C build --print-errorlogs
+ dbus-run-session xvfb-run -s '-nolisten local' \
+ meson test -C build --print-errorlogs
)
package() {
- depends+=(libmutter-8.so)
+ depends+=(libmutter-9.so)
meson install -C build --destdir "$pkgdir"
}