summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80648496e5d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gabriele Musco <gabmus@disroot.org>
+# Upstream URL: https://gitlab.gnome.org/ZanderBrown/gnome-source-thumbnailer
+# Modified from Eric BĂ©langer <eric@archlinux.org> PKGBUILD of python-feedparser
+
+pkgname=gnome-source-thumbnailer-git
+pkgver=3e1503c
+pkgrel=1
+pkgdesc="Thumbnails for your code"
+arch=('any')
+url="https://gitlab.gnome.org/ZanderBrown/gnome-source-thumbnailer"
+license=('GPL-3.0')
+makedepends=('python-setuptools' 'git')
+depends=('python')
+conflicts=('gnome-source-thumbnailer')
+source=("gnome-source-thumbnailer::git+https://gitlab.gnome.org/ZanderBrown/gnome-source-thumbnailer.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/gnome-source-thumbnailer"
+ git describe --always --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/gnome-source-thumbnailer"
+ python setup.py install --root="${pkgdir}"
+}