summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e51b3c29bd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-system-monitor-git
+pkgver=3.31.3.r5.g56ebc51b
+pkgrel=1
+pkgdesc="View current processes and monitor system state"
+url="https://wiki.gnome.org/Apps/SystemMonitor"
+arch=(x86_64)
+license=(GPL)
+depends=(libgtop gtkmm3 librsvg systemd)
+makedepends=(meson yelp-tools git)
+provides=(gnome-system-monitor)
+conflicts=(gnome-system-monitor)
+source=("git+https://gitlab.gnome.org/GNOME/gnome-system-monitor.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gnome-system-monitor
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson gnome-system-monitor build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}