summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 35 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e9f1665afb9..4dc91555ff16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,47 @@
-pkgname=gnome-weather-git
-_pkgname=gnome-weather
-pkgver=3.34.0+27+g07c3cf5
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
+_pkgname="gnome-weather"
+pkgname="${_pkgname}-git"
+pkgver=44.0+20+g741d71c
pkgrel=1
pkgdesc="Access current weather conditions and forecasts"
url="https://wiki.gnome.org/Apps/Weather"
arch=(any)
license=(GPL)
-depends=('gtk3' 'gjs' 'libgweather' 'geoclue2' 'gnome-desktop')
-makedepends=('gobject-introspection' 'appstream-glib' 'git' 'meson')
-provides=('gnome-weather')
-conflicts=('gnome-weather')
-groups=('gnome')
-source=("git+https://gitlab.gnome.org/GNOME/gnome-weather.git")
+depends=(
+ geoclue
+ gjs
+ gtk4
+ libadwaita
+ libgweather-4
+)
+makedepends=(
+ appstream-glib
+ git
+ gobject-introspection
+ meson
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+groups=(
+ gnome
+ gnome-git
+)
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd "${_pkgname}"
+}
+
build() {
- arch-meson $_pkgname build
- ninja -C build
+ arch-meson "${_pkgname}" build
+ meson compile -C build
}
check() {
@@ -29,5 +49,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
}
+
+# vim:set sw=2 sts=-1 et: