summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec0bc378debd..1aac835a2f38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=gnucash-xbt
_pkgname=gnucash
-pkgver=3.2
-pkgrel=2
+pkgver=3.5
+pkgrel=1
_sourcerel=
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
arch=(x86_64)
url="http://www.gnucash.org"
license=(GPL)
depends=(aqbanking boost-libs webkit2gtk libsecret)
-makedepends=(boost cmake gmock gwenhywfar libdbi libdbi-drivers libmariadbclient postgresql-libs)
+makedepends=(boost cmake gmock libdbi libdbi-drivers mariadb-libs postgresql-libs)
optdepends=(
'gnucash-docs: for documentation'
'iso-codes: for translation of currency names'
@@ -21,16 +21,14 @@ options=(!emptydirs)
conflicts=(gnucash gnucash-devel)
provides=(gnucash)
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
- "xbt.patch"
- "0001-Fix-compiler-warning-issues.patch")
-sha1sums=('4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd'
- '52cf6820bf1dd87b5807997e49ec9c861ff516af'
- '2a206572b385288fd4a7dd9b2bedb2b793d4ca2b')
+ "xbt.patch")
+
+sha256sums=('776d0b51b6029e25b5c7e9eb86021d5ecf1b09d8f3241b279f76dba9cc3b7745'
+ '8cf12425a9f66c69473d83582742244889dc0ffb854d3a502aca58bc649878d4')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
- patch -Np0 -i "${srcdir}/0001-Fix-compiler-warning-issues.patch"
cd "${srcdir}"
mkdir build
@@ -48,7 +46,7 @@ prepare() {
build() {
cd "${srcdir}/build"
- make -j8
+ make
}
package() {