summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f308207ca86..2385afe4c030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=gnucash-xbt-minimal
_pkgname=gnucash
-pkgver=3.2
-pkgrel=2
+pkgver=5.5
+pkgrel=1
_sourcerel=
pkgdesc="A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support"
-arch=(x86_64)
+arch=(x86_64 aarch64)
url="http://www.gnucash.org"
license=(GPL)
-depends=(webkit2gtk boost-libs guile libsecret)
-makedepends=(boost cmake gmock libdbi libdbi-drivers libmariadbclient postgresql-libs)
+depends=(webkit2gtk boost-libs libdbi libdbi-drivers guile libsecret)
+makedepends=(boost cmake gmock libmariadbclient postgresql-libs swig)
optdepends=(
'gnucash-docs: for documentation'
'iso-codes: for translation of currency names'
@@ -21,16 +21,14 @@ options=(!emptydirs)
conflicts=(gnucash gnucash-devel gnucash-xbt)
provides=(gnucash)
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
- "xbt.patch"
- "0001-Fix-compiler-warning-issues.patch")
-sha1sums=('4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd'
- '52cf6820bf1dd87b5807997e49ec9c861ff516af'
- '2a206572b385288fd4a7dd9b2bedb2b793d4ca2b')
+ "xbt.patch")
+
+sha256sums=('b4daf67bb892b706323f62e9fa97242039d7dd0a2e1e10771e0c25817dd0ed3b'
+ '8cf12425a9f66c69473d83582742244889dc0ffb854d3a502aca58bc649878d4')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
- patch -Np0 -i "${srcdir}/0001-Fix-compiler-warning-issues.patch"
cd "${srcdir}"
mkdir build
@@ -49,7 +47,7 @@ prepare() {
build() {
cd "${srcdir}/build"
- make
+ make -j 6
}
package() {