summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a34d041d601..edb8931b711d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,9 @@ conflicts=("${_appname}")
depends=('libextractor' 'sqlite' 'gnurl'
'libmicrohttpd' 'jansson')
makedepends=('gettext' 'pkgconfig' 'autoconf' 'fakeuser-git'
- 'bluez-libs' 'python' 'glpk' 'libpulse' 'opus')
+ 'bluez-libs' 'python2' 'glpk' 'libpulse' 'opus')
optdepends=('bluez-libs'
- 'python'
+ 'python2'
'glpk'
'libpulse'
'opus'
@@ -66,8 +66,12 @@ prepare() {
cd "${srcdir}/${_appname}"
- # zbar only has bindings for python2
- sed -i '1s/python/python2/' gnunet/src/util/gnunet-qr
+
+ # zbar (required by gnunet-qr) only has bindings for python2, so we have to use python2
+ # Not sure whether other parts of Gnunet fully support Python v3.0. It does build with v3.
+ # NOTE: can't override in aclocal.m4 (that file is autogenerated)
+ _redefine_py="m4_define_default([_AM_PYTHON_INTERPRETER_LIST],[python2])"
+ sed -i "0,/^AM_PATH_PYTHON.*/s/^AM_PATH_PYTHON.*/$_redefine_py\n&/" configure.ac
autoreconf -fi
sed -i 's|contrib doc|doc|' Makefile.*