summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 41 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2476f75acada..43b2f83810d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# GnuPG2 GIT version
-# Maintainer: alphazo@gmail.com
-# Based on official package maintained by Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: alphazo@gmail.com
+# Based on official package
# Cleanup from @holos
_gitname=gnupg
pkgname=gnupg-git
-pkgver=2.1.0+beta834+21+g688a903
+pkgver=2.2.0+12+g9f5e50e7c
pkgrel=1
-pkgdesc="GNU Privacy Guard 2 - a PGP replacement tool. Development version. Do not use in production environments. Test new ECC algorithms by using \"gpg --full-gen-key --expert\""
-arch=('i686' 'x86_64')
-depends=('libldap' 'curl' 'bzip2' 'zlib' 'libksba>=1.2' 'libgpg-error-git' 'libgcrypt-git'
- 'pth' 'libusb-compat' 'libassuan-git' 'npth-git' 'texinfo' 'readline' 'pinentry')
-license=('GPL')
+pkgdesc='Complete and free implementation of the OpenPGP standard - development'
url="http://www.gnupg.org/"
-makedepends=('git' 'ghostscript' 'transfig' 'automake-1.11')
+license=('GPL')
+arch=('i686' 'x86_64')
+optdepends=('libldap: gpg2keys_ldap'
+ 'libusb-compat: scdaemon')
+makedepends=('git' 'libldap' 'libusb-compat')
+checkdepends=('openssh')
+depends=('npth-git' 'libgpg-error-git' 'libgcrypt-git' 'libksba' 'libassuan-git'
+ 'pinentry' 'bzip2' 'readline' 'gnutls' 'sqlite')
provides=("gnupg=${pkgver}" 'dirmngr')
conflicts=('gnupg2' 'gnupg' 'dirmngr')
install=${pkgname}.install
@@ -21,29 +25,42 @@ source=("git://git.gnupg.org/gnupg.git")
sha1sums=('SKIP')
pkgver() {
- cd "$_gitname"
+ cd "$_gitname"
+ git describe --tags | sed 's/gnupg-//;s/-/+/g'
+}
- git describe --tags | sed 's/gnupg-//;s/-/+/g'
+prepare() {
+ cd "${_gitname}"
+ ./autogen.sh
+ sed '/noinst_SCRIPTS = gpg-zip/c sbin_SCRIPTS += gpg-zip' -i tools/Makefile.in
}
build() {
- cd "$_gitname"
-
- AUTOMAKE_SUFFIX="-1.11" ./autogen.sh --force
+ cd "${_gitname}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/gnupg \
+ --enable-maintainer-mode \
+ --enable-symcryptrun \
- ./configure \
- --enable-maintainer-mode \
- --prefix=/usr \
- --libexecdir=/usr/lib/gnupg
+ make
+}
- make
+check() {
+ cd "${_gitname}"
+ make check
}
package() {
- cd "$_gitname"
+ cd "${_gitname}"
+ make DESTDIR="${pkgdir}" install
+ ln -s gpg "${pkgdir}"/usr/bin/gpg2
+ ln -s gpgv "${pkgdir}"/usr/bin/gpgv2
- make DESTDIR=${pkgdir} install
- ln -s gpg2 "$pkgdir/usr/bin/gpg"
+ cd doc/examples/systemd-user
+ for i in *.*; do
+ install -Dm644 "$i" "${pkgdir}/usr/lib/systemd/user/$i"
+ done
}
-
-# vim: ft=sh syn=sh et sw=2