summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e44d34bf7b5..e3d76d859351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=gnutls-git
-pkgver=3.6.13.r104.g52e78f1e3
+pkgver=3.7.7.r21.g66f511895
pkgrel=1
pkgdesc="A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them"
arch=('i686' 'x86_64')
url="https://www.gnutls.org/"
license=('LGPL')
-depends=('glibc' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
-makedepends=('git' 'autogen' 'gperf' 'rsync' 'wget')
-provides=('gnutls')
+depends=('glibc' 'brotli' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
+makedepends=('git' 'autogen' 'gperf' 'gtk-doc' 'rsync' 'wget')
+provides=("gnutls=$pkgver")
conflicts=('gnutls')
+options=('!zipman')
source=("git+https://gitlab.com/gnutls/gnutls.git")
sha256sums=('SKIP')
@@ -27,14 +28,25 @@ build() {
./bootstrap
./configure \
--prefix="/usr" \
- --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit" \
--disable-full-test-suite \
- --disable-guile
+ --enable-openssl-compatibility \
+ --with-default-trust-store-pkcs11="pkcs11:"
make
}
+check() {
+ cd "gnutls"
+
+ #make check
+}
+
package() {
cd "gnutls"
make DESTDIR="$pkgdir" install
+
+ # lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
+ # gzip -9 all files in infodir and manpages manually
+ find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -n -9 {} \;
+ find "$pkgdir/usr/share/man" -exec gzip -n -9 {} \;
}